Print file generator issues reported
Incident Report for Printful
Resolved
This issue has been resolved
Posted Mar 22, 2022 - 21:58 UTC
Identified
The issue has been identified and we are working on a fix
Posted Mar 22, 2022 - 21:41 UTC
Investigating
We are currently investigating the issue
Posted Mar 22, 2022 - 20:42 UTC
This incident affected: Printful.com (Printful.com).