Printful Texas facility is closed due to a snowstorm
Incident Report for Printful
Resolved
Printful Texas facility has reopened. The temporary closure didn’t affect the fulfillment times for your orders.
Posted Feb 02, 2023 - 08:28 UTC
Monitoring
Today, Jan 31, we’re closing our Texas facility due to weather conditions caused by a snowstorm. We don’t expect this to affect our fulfillment times, and we hope to reopen tomorrow. We'll post an update here as soon as we know more.
Posted Jan 31, 2023 - 09:15 UTC
This incident affected: Fulfillment centers (Dallas, TX).