Order and product import delays
Incident Report for Printful
Resolved
Incident resolved. Please press Refresh data if you experience any lingering issues.
Posted Feb 01, 2023 - 17:23 UTC
Monitoring
We're experiencing slowdown in order and product import functionality. This means that new orders might not get imported instantly and newly pushed products won't appear with pictures on Printful's side right after they're pushed to your store.

All orders and products will be imported, but it might take up to an hour. Please press Refresh data if you experience any issues.
Posted Jan 31, 2023 - 15:41 UTC
This incident affected: Integrations (Shopify, Wix, Squarespace, WooCommerce, Webflow, Ecwid, BigCommerce).