Squarespace connectivity issues
Incident Report for Printful
Resolved
Connectivity issues with the Squarespace integration are resolved and normal operations are resuming.
Posted Oct 31, 2024 - 08:41 UTC
Update
Connectivity issues with the Squarespace integration are resolved and normal operations are resuming.
Posted Oct 31, 2024 - 08:39 UTC
Investigating
We're experiencing connectivity issues with Squarespace integration. This affects all basic integration functionality (product push, store sync, order sync, etc.). We are communicating with Squarespace to resolve this issue as soon as possible.

We apologize for any inconvenience.
Posted Oct 31, 2024 - 06:21 UTC
This incident affected: Integrations (Squarespace).