File upload issues
Incident Report for Printful
Resolved
The root cause has been fixed. It might take additional 30-60 minutes for some of the pending files to get processed.
Posted Nov 18, 2022 - 23:36 UTC
Identified
We have identified the issue and are now working on a fix.
Posted Nov 18, 2022 - 23:17 UTC
Investigating
We are currently investigating reports about file uploading taking longer than usual.
Posted Nov 18, 2022 - 22:49 UTC
This incident affected: Printful.com (Printful.com, API).