File library upload issue
Incident Report for Printful
Resolved
The incident has been resolved.
Posted Dec 12, 2022 - 19:46 UTC
Identified
The issue has been identified and fixed in progress.
Posted Dec 12, 2022 - 19:20 UTC
This incident affected: Printful.com (Printful.com).