Issue with product push wait time for all integrations

Incident Report for Printful

Resolved

We have made the necessary adjustments and service speed is recovering. It may take 1-2 hours for the product push speed to return to normal.
Posted Oct 18, 2023 - 22:20 UTC

Investigating

We are currently investigating this issue.
Posted Oct 18, 2023 - 20:57 UTC